Taxes multiples dans les notes de frais #2

Bonjour chÚre communauté Dokos !

AprĂšs quelques recherches, j’ai vu un sujet similaire Ă  celui-ci (Taxes multiples sur les dĂ©penses de note de frais), mais ma question porte ici sur le calcul des TVA multiples, et non sur la sĂ©lection du bon taux de taxe dans les lignes de taxes. Je me permets donc d’ouvrir un nouveau thread ! :wink:

Lors de la saisie d’une note de frais, ou d’une facture d’achat, en particulier lorsque j’ajoute un article/dĂ©pense, les Taxes et Frais relatifs Ă  cet·te article/dĂ©pense remontent correctement.
Par exemple, lorsque je choisi un article taxĂ© Ă  20%, j’ai bien une ligne TVA sur Achats 20% qui apparait, et lors de l’ajout d’un article exonĂ©rĂ©, j’ai bien une ligne TVA ExonĂ©rĂ©e 0%.

Toutefois, comme le montre la capture ci-dessus, c’est le total gĂ©nĂ©ral de la note de frais qui est repris pour le calcul des 20% de TVA (120€+50€), alors que seuls les 120€ sont assujetis Ă  hauteurs de 20%.

Voici le paramétrage des deux Types de notes de frais saisis dans la note de frais capturée ci-dessus :

Type de note de frais : Achat de petits matériels

Type de note de frais : HĂ©bergements/Hotels

Quelqu’un d’entre vous aurait-il Ă©galement constatĂ© ce comportement ?
Est-ce « normal Â», liĂ© Ă  un paramĂ©trage erronĂ©, ou bien simplement un bug ?

Merci beaucoup pour vos lumiĂšres !
TrÚs bonne journée à tous,

1 Like

Bonjour @Yoan_Castellani,

Actuellement la seule mĂ©thode permettant d’avoir un calcul correct avec plusieurs taux de TVA consiste Ă  laisser le systĂšme calculer tout seul la TVA sur la base de la configuration des types de notes de frais.

Dans ton exemple, dĂ©coche la case `Set taxes manually" et la ventilation devrait ĂȘtre correcte.

En mode manuel, le calcul est effectué sur le total général.

Bonne fin de journée !

2 Likes

Bonjour et merci Charles-Henri !

En effet, en dĂ©cochant « Set taxes manually Â», les montants des taxes est plus cohĂ©rent avec les taxes configurĂ©es pour chaque article !

La checkbox suivante « Taxes incluses dans le montant des dĂ©penses Â», toutefois, si elle est cochĂ©e, devrait intĂ©grer la taxe dans les montants saisis au dessus, mais cela ne se fait que si la premiĂšre coche est cochĂ©e. Cela semble logique au vu du formulaire de personnalisation (avant mes modifs) qui n’affiche cette checkbox que si « Set taxes manually Â» est cochĂ©e.

Or, je ne peux pas la cocher, d’aprùs ce que tu me dis ! :sweat_smile:

Dans l’idĂ©al, chacun devrait pouvoir saisir les montants qu’il dĂ©pense, sans se soucier de la TVA.
Est-ce possible sans passer par la crĂ©ation d’une dĂ©pense au prĂ©alable ?

TrÚs bonne journée !
Merci encore :slight_smile:

1 Like