Problème à l'installation de Dokos - 'db_user' is not defined

Bonjour,
J’ai suivi l’installation de la V4 : Installation standard · Dokos Documentation
et je suis bloqué sur la ligne de commande « bench new-site monsite.dokos.cloud »
J’ai le message d’erreur suivant:

Sauriez-vous me dire ce que j’ai raté ?
Je vous remercie.

Yann B.

Bonjour Yann,

Malheureusement c’est un bug introduit cette semaine qui n’a pas encore décelé.
Éventuellement tu peux utiliser une version antérieure de Dodock (frappe) comme v4.14, ou attendre le correctif.

Corentin

1 Like

Bonjour,
Je vous remercie pour votre retour.
A quel moment dans l’installation peut-on spécifier que l’on souhaite la v4.14 de Dodock ?

Yann B.

Le bug d’installation a été corrigé dans Dodock v4.15.2.

Il faut donc tirer la dernière version de l’appli avec cette commande :

cd apps/frappe
git pull

J’ai pu créer le site.
Par contre, je n’ai pas l’impression qu’il soit actif : la page ne s’affiche pas sur localhost. Le port 80 n’a pas l’air utilisé sur ma machine.

Avec la commande bench use monsite.dokos.cloud, tu peux définir un site par défaut qui sera accessible avec le nom localhost. Sinon, peut-être que tu peux accéder directement au site avec son nom de domaine, éventuellement en rajoutant une entrée dans /etc/hosts ?

Est-ce que bench setup production $USER a fonctionné ?

C’est bon après un setup production $USER, merci !

Mon site créé n’a pas l’air en forme:

Ah très bien, maintenant une dernière commande : chmod +x /home/$USER

Le site s'affiche sans mise en forme ni couleurs ? Vérifiez que votre dossier utilisateur serveur est bien accessible pour Nginx. Vous pouvez donner les droits de lecture en lançant

1 Like