Customisation format d'impression facture

Bonjour à toutes et tous,
Il n’est pas encore trop tard pour vous souhaiter une excellente année 2021, en espérant que celle-ci soit moins Rock and Roll que la précédente :wink:

Voilà, j’écris ce poste aujourd’hui, car je ne suis pas dégourdi, et je n’arrive pas à “dériver” le template d’impression de facture (à laide la fonction “dupliquer” si j’ai bien compris).

Mon côté un peu psycho rigide veut que je veuille enlever “de vente” pour ne garder que “Facture” sur la vue d’impression. Je suis allé dans Paramètres > Format d’impression. Quand je veux modifier l’entête de la vue “Sales Auditing Voucher” > “Modifier le format” > “Modifier l’entête”, je modifie mon entête, mais quand je souhaite enregistrer ma modification, j’ai “Le format d’impression standard ne peut pas être mis à jour”.

J’ai cru comprendre que c’est normal, car il n’est pas possible de modifier une vue par défaut. J’ai bon ? Maintenant, quand j’édite à nouveau cette vue “Sales Auditing Voucher” que je choisis “dupliquer” dans le menu, bah , je n’ai plus la présentation wysiwyg de la vue, et apparemment je ne peux utiliser que Jinja ou Js pour modifier ma vue.

Est-ce que quelqu’un parmi vous pourrait me dire à quel endroit je me foire ?
Merci par avance.
Je vous souhaite une belle journée.

Edit: je crois que j’ai dit une bêtise, il s’agit de la vue “Sales Invoice Return” et non “Sales Auditing Voucher”.

Bonjour Stéphane,

Tu fais ce qu’il faut, le problème vient simplement du fait qu’en dupliquant un format d’impression “standard” (codé dans le logiciel) il y a un champ “standard” caché qui est dupliqué également alors qu’il ne devrait pas. Ca t’empêche d’enregistrer ton nouveau format d’impression…
Je vais corriger ce problème dans une prochaine version.

En attendant, vas simplement dans Format d’impression > Nouveau format d’impression et sélectionne “Facture de vente” comme document de référence.
Tu pourras ensuite personnaliser ton format d’impression comme tu le souhaite. (Sales Invoice Return est un format pour les avoirs, non les factures).

Attention tu as deux modes de personnalisation de factures:

  1. En cliquant sur le bouton “Modifier le format”, tu accèdes à la page avec les menus en glisser-déposer
  2. Si tu coches l’option “Format personnalisé”, tu peux faire un format en Jinja

De manière encore plus simple, si tu souhaite renommer Facture de ventes en Facture, va dans la liste des factures de vente, cliques sur Menu (…) > Personnaliser et met Facture dans le champ “Modifier le libellé”.
Ensuite cliques sur ton avatar dans la barre de navigation, puis Recharger pour prendre en compte la modification.

Bonne soirée!

PS: Le lien vers la documentation sur les formats d’impression: https://doc.dokos.io/fr/getting-started/print-formats

Bonjour Charles-Henri,
Excuse-moi pour cette réponse tardive (semaine un peu Rock and Roll :smiley: ). Je vais tester en suivant tes instructions ce week-end. J’avais effectivement tenté de suivre la documentation avant de venir poster ici, mais apparemment il y avait quelque chose que je faisais mal, car ce n’était pas l’effet attendu.
Bon week-end.

Bonsoir à toutes et tous,
Je suis sincèrement désolé pour le temps de réponse. J’ai suivi ton mode opératoire Charles-Henry, c’est nickel, j’ai réussi à faire ma popote. Merci beaucoup pour ton aide. Ce qui était désarçonnant et ce pourquoi j’utilisais le mauvais gabarit, c’est que je ne voyais jamais listé “Facture de vente”, il a fallu que je saisisse une grosse partie du libellé dans le champs nom pour que la complétion me le propose :slight_smile:

En tous cas, le problème est résolu.
Bonne soirée.

1 Like